Monday, October 05, 2009

Deployment Issue: Crystal Reports embedded with .NET web application

Lot of people comes across the issue of Crystal Report deployment on production server. When they run the web application with reports embedded in to it, developed using Crystal Reports, it works fine on their machine but when they deploy the same web application on deployment machine, it gives exception as soon as any report is opened.

The problem here is that you have the CR runtime assemblies on your local machine; it's because you have installed VS, and CR runtime comes embedded in VS now. But on the production machine, we just have .NET framework, not the CR runtime.

So in order to make it run on production machine do the following:

  1. Create a new web setup project for your web application using VS web setup wizard and add your project output to it.
  2. Add appropriate merge modules (it installs the CR runtime on production server) to the setup project depending on .NET framework and CR version.

When we'll install the web application using the above created setup project, it will start working on production server as well.

Here is a tutorial that will help you do the above steps:

http://resources.businessobjects.com/support/communityCS/TechnicalPapers/crnet_deployment.pdf

Happy Deployment! J

*CR= Crystal Report

*VS = Visual Studio

3 comments:

123 123 said...

Great article you got here. It would be great to read more concerning this theme.
By the way check the design I've made myself London escort

joven said...

beautiful blog..pls visit mine and be a follower.. thanks and God bless..

http://forlots.blogspot.com/

Muhammad Azeem said...

This is a nice article..
Its very easy to understand ..
And this article is using to learn something about it..

c#, dot.net, php tutorial

Thanks a lot..!